Loading...
 

OM32, OC32 and LichtOrgel


Geen communicatie tussen PC en OC32/NG-A

Netherlands

LS,

Helaas weer een topic waarin de communicatie tussen PC en OC32 faalt.
Ik heb sinds een aantal dagen een nieuwe OC32/NG-A + een U485J USB converter. Deze zijn aangesloten en voor zover mogelijk geinstalleerd.
De U485J met een catkabel aan de OC32/NG en deze gevoed met 12V DC. Groene ledje knippert regelmatig, De drivers zijn automatisch door Windows 10 geinstalleerd en daarna is er een vrije compoort gekozen. tot zover lijkt alles goed te zijn.
Maar bij het opvragen van de firmware versie komt al direct de melding: "No response received, resetting bidirectional communication".
Daarna van alles geprobeerd wat ook al in voorgaande topics werd aanbevolen zoals het controleren en uitproberen van de dip switches maar ook dat had geen enkel resultaat. heeft er iemand enig idee wat het probleem is en/of een oplossing hiervoor?

m.v.g.
Rien

Netherlands
Flitst de oranje LED op de U485 als je een commando geeft?
Netherlands
De oranje led flitst niet bij een opdracht alleen heel kort bij het opstarten. Gr. Rien
Netherlands
Dan heb je (zeer waarschijnlijk) niet de juiste com-poort geselecteerd.
Netherlands

Hm.. zou kunnen maar er is in principe maar 1 com poort beschikbaar, in mijn geval .com 8. Zodra ik iTrain opgestart heb worden .com 3 en 4 ook zichtbaar. Moet daar dan een keuze uitgemaakt worden? Ik zal het in ieder geval morgen gaan proberen
.

Belgium

Of misschien een verkeerde module adres geselecteerd ? (maar dan zou de oranje LED moeten werken zeker .... )
In Dinamo wordt vanaf 0 geteld , staat het vinkje aan bij "Start numbering at 1" moet je 1 bijtellen. (dus OC32 op adres 0 wordt 1)

Netherlands
Vinkje staat aan. Moet er dan misschien nog iets met de dip switches gebeuren? Eerlijk gezegd ben ik hier ook al mee aan het expirimenteren geweest maar dat had geen enkel resultaat.

Belgium

Bij mij staat in het OC32 config (release 3.10) programma : "Use Dinamo Tunneling" aangevinkt , zo kan ik de firmware versie uitlezen van de OC32NG.
Zoniet , kreeg ik ook die melding "No response received, resetting bidirectional communication"


Netherlands

Claudio,
Klopt, maar dat geldt voor een Dinamo systeem, niet bij een OC32 aan een U458

Belgium
Oops , Ik zag het net in zijn eerste postje (had wat te snel over gelezen) , mijn excuses voor de verwarring.redface

Netherlands

Als de communicatie tussen U485(J) en OC32(/NG) niet werkt zijn er feitelijk maar 5 mogelijke oorzaken.

  • Verkeerd gemonteerde RS485 kabel. Bij de U485 komt dit nog wel eens voor. Bij de U485J eigenlijk vrijwel nooit.
  • Verkeerd modulenummer geselecteerd.

Bovenstaande oorzaken kun je vinden door te kijken of de oranje LED op de U485 flitst als je een commando naar de OC32 stuurt. Oranje betekent zenden, groen is ontvangen. Als er niets flitst wordt er dus niets gezonden en kun je bovenstaande oorzaken uitsluiten.

  • Verkeerde com-poort geselecteerd.

De juiste com-poort is als volgt te vinden:

  • Sluit alle programma's
  • Verwijder de U485
  • Start OC32Config
  • Kijk welke com-poorten je kunt selecteren.
  • Steek de U485 in (en wacht een seconde of 10)
  • Klik in OC32Config op Refresh
  • Kijk welke com-poorten je kunt selecteren. Als het goed is heb je er één extra. Die dus.

Bovenstaande staat overigens ook in de handleiding.

  • Als je met bovenstaande procedure géén extra com-poort ziet is je U485 niet goed geconfigureerd door Windows.
  • Dan kan uiteraard ook nog de OC32 of U485 defect zijn. Maar hoewel velen dit als meest voor de hand liggende oorzaak aanwijzen blijkt dit o.b.v. ervaringscijfers bij nieuwe modules bijna nooit het geval te zijn.

Mvg,
Leon


Netherlands
Als je het modulenummer wijzigt door de dipswitches een andere stand te geven dan moet je de OC32 eerst even spanningsloos maken. Want de stand van de dipswitches wordt alléén bij het opstarten van de OC32 ingelezen.
Netherlands

Martin,

na experiment met dipswitches is uiteraard de OC32 even spanningsloos geweest en weer opgestart.

Leon,
Er is nog een zesde mogelijkheid bijgekomen en dat is dat de catkabel niet goed is of was.
Na alle aanbevelingen zonder resultaat uitgevoerd te hebben, heb ik als laatste wanhoopsdaad de cat kabel verwisselt voor een andere en direct communiceerde de U485J met de OC32NG-A, eindelijklol. allen bedankt voor de moeite van het meedenken.

m.v.g.
Rien

Netherlands

In die mogelijkheid was al voorzien. Ik schreef dat het "vrijwel nooit" voorkomt.
Maar dan klopt toch jouw analyse niet. De vraag was "flitst de oranje LED als je een opdracht stuurt". Antwoord was "nee". Als je kabel stuk is zendt de U485(J) gewoon,alleen komt het nooit aan bij de OC32.
Maar wel mooi is dat het werkt biggrin

Mvg, Leon

Netherlands

Ik keek naar de led op de OC32

Mvg
Rien


 
British English (en-uk)Dutch (Nederlands, nl)German (Deutsch, de)